Canoscan 4400f mac failed to open driver

If you can't get the scanner going using tips from previous reports here use browser 'find' search for your brand or model. The same drivers also work with ScanWizard Pro 7 v7. I downloaded the trial and it immediately recognized the scanner. I have to say that VueScan is a very nice piece of software. Much better than Canon's toolbox. Very easy to use and it comes with built-in tutorials which were great for my dad.

ScanWizard Pro 7. You can, of course change it in the finder or a folder when the scan is completed. Microtek is aware of these issues and doesn't seem to be in a hurry to fix them. Otherwise there seems to be no other issues. My scanner: a Canoscan F. I just moved from a similar mac but running OS I kept getting a message, driver not found, on running CanoScan toolbox or on pressing the scanner's buttons.

I downloaded the latest Canoscan from Canon's website and installed that - still no luck. Then I realised I needed ScanGear as well, the actual driver. The new version of Scangear on Canon's website has the cheery message that the Canoscan toolbox won't work with it. It's not a great front end but better than none.

So I followed earlier advice on this site and deleted every trace of Canon software, including in both my user library and the system library. My lessons learnt: do hunt down all trace of earier software Find the previous versions of software and install those. Thanks for the hints, I thought my scanner was binfood then. Please share this info with others so they may also benefit from what I've found out BTW, I called Canon technical support and they could figure out what was going on.

The 4 buttons on the left are used to scan and generate PDF files. I was able to get the scanner to scan using the supplied software from Canon and using Image Capture, but I was not able to get the scanner buttons to work. I followed the instructions from Canon, which were to: 1. Open up Image Capture 2. Go to Preferences and click the option under "Scanner" that says "When Image Capture is launched, open scanner window" 3. Then in the Scanner window, click on the "Options Then click on "Buttons" 5. Make sure "CanoScan Toolbox 5.

What was supposed to happen was CanoScan Toolbox was supposed to launch and initiate the action associated with the button. Here's how I fixed it: 1. At first I didn't do the "Save" step open toolbox, and then click the "Save" icon and the behavior of the buttons was unchanged and incorrect. Then I did the "Save" step, but only clicked on "Apply" on the dialog box that then pops up.

The behavior was still unchanged and correct. This time, the buttons worked as they are supposed to!!! Hitting any of the buttons launched Toolbox and performed the correct actions associated with the buttons. In fact, it worked better than the Canon tech support people told me it would work. They told me that only the 3 right-most buttons work with a Mac and the 4 left-most buttons would only work with Windows.

I've found that all the buttons work. However, Toolbox doesn't seem to reflect the mappings of the 4 right-most buttons in its user interface and doesn't let you change the mappings, like you can for the 3 right-most buttons. Anyways, in summary, the key for me was doing the "Save" step, but doing it completely by letting it save a file.

I don't think this was clear from the other comments. Hopefully this info will help someone else. I was going to return this scanner, but now I think I'll keep it. HP Photosmart Studio v. Frustrating, but I did get it running -Doug G. Some previous LiDE 30 owners said they had problems installing the canon software. Also see reminder below on Canon software install order tips from a Jan 9th report helped.

Canon does not provide a utility that removes prior toolbox versions. I followed the procedure from the January 9th report for the CanoScan F, and it worked fine. I also reinstalled everything for my larger F scanner, but have not tested it yet. The CS3 problem is quite annoying There's some earlier Epson user reports that noted Pshop scanning worked after some troubleshooting but didn't mention if they were using a PPC or Intel-based Mac or what PShop version they were using CS2 and earlier isn't Universal, so it runs under Rosetta by default on Intel-based Macs.

The icon appears short and vanishes every time. For the following steps I used the HD service program. This took me several hours. Now I recovered the Macintosh HD image - again several hours to wait. But after that, first "new" start and? Epson Scan finally works again! Kind regards, Dirk T. I have the following: Mac Pro 2 x Quad 2. Lo and behold that now allows me to see and use the scanner.

Note - although other owners didn't mention that, there was an different Epson scanner model user that also noted using Rosetta mode made Epson Scan 2. It works great on my dual G5 Mac Pro running Leopard Hope this helps others After my own futile and frustrating attempts to get the Epson to work successfully by going through all the usual troubleshooting and reinstalling I called them. The technician walked me through a few steps to delete some things from the library and application support.

I believe the following files were what he walked me through in deleting which successfully got me back up and running: 1. The scanner now launches properly from Photoshop and from the scanner app itself!!!! Hope this helps if you didn't already have it resolved Just for the record What Mac Model? PPC or Intel-mac? System is an iMac Core 2 Duo with Scanner plugged in to iMac USB directly. The "Can't load driver" issue. After much playing around I was able to get the CanoScan software working again. In reading through the postings it seems Canon and Apple are pointing fingers at each other.

Bottom line is that the Canon software for the can be made to work. Your results may vary. I also checked the permissions on the driver itself which on my system seemed to be possibly be set incorrectly. One of the permissions was set to "No Access" which I changed to "Read Only" you will have to authenticate to do this.

I'd first try the plist mod making sure you lock the file. Restoring the edited plist file "fixes" it. Hope this helps someone It also works with Tiger. You'll find better results connecting the scanner through USB and not firewire. I can use firewire with Epson Scan 2. Don't ask me why it just the way it is for now. The uninstaller does NOT rid the Mac of all traces. Use Spotlight to find the remainder. I have screwed with this entire scenario for many weeks and even dialogued with the Epson support who btw are not listening too effectively and this is the only way I can get that Epson software to run well with that scanner.

If you would like to see an example I'll send you two files later if asked. I took a clip from each and created this composite web page size for posting: I'm not a graphics pro but remember the days before Photoshop added a "healing brush", a very useful tool for this. Still can be tedious, but a huge plus. As posted previously the key seems to be installing in the correct order i. If you then select "Save" from the toolbox then it seems to be working just fine.

FYI: see earlier report from Jan. May not help but I'd try a direct connection also. Fortunately I still have my old iMac running Just a pain in the backside. But thanks to all for the various suggestions. Left off until needed for use. Used the latest Epson software for it - Epson Scan app 2. Using the latest driver download, which is listed as 2. Epson Scan 2. It launches and immediately quits.

I asked if he'd done a get info in the finder and selected to "open using Rosetta ". A previous report here mentioned that Epson Scan 2. Other applications that are listed as "Application Universal " have a checkbox below to allow me to force them to run in Rosetta if I want to. So far the Epson stuff all appears to still be PPC only. Of course this one doesn't run for me - so who knows what's going on. Just more data for you. I'll let you know if Epson gets back to me with any useful information.

Repeated reboots and moving of the USB cable from port to port have had no effect. I do not have Photoshop on this machine yet, but Image Capture does not recognize any "Image Capture Device" when launched. I was able to produce clear scans, but the interface is iffy. Saving the image is a strange semi-automatic process that lacks any sort of traditional Mac interface consistency.

So - it can be made to work, but it's not right yet. Thanks for the always helpful site. In Mac OS Sent email to Canon support. A previous report from Jan 9th from a Canoscan F owner different model below mentioned Canon support stated a specific software install order. I did not install any Epson driver software I hate using third-party drivers unless absolutely necessary as they invariably go out of date and in my experience often cause problems , and I just use Image Capture to perform the scanning.

The scanner is plugged directly into the computer via USB. I've had this scanner for a few years, I only use it intermittently it's usually unplugged , and I haven't stressed the capabilities or anything, but I had the opportunity to use it the other day and it worked fine. I didn't see it included in your scanner report, so I thought I'd send in this note. Thanks for a great resource!

I did not know that this was a possibility so I tried it and it worked quite well. I had been using VueScan V8. I noticed that VueScan had been updated to correct this problem so I went ahead and downloaded the new version and tried to replace the old version 8. The crop problem seems to have been corrected. I will have to play around with ImageCapture a little more to see what the results are Right now, ImageCapture does not seem to involve VueScan. I asked if he'd tried using Preview after seeing a note on that from another reader -Mike Hey, It works I made a selection of what to scan and it works fine.

PowerMac Dual G5 2. I've tried to download the software from Canon's site but I get the following messages screenshots sent - here's the text of them-Mike from finder attempt to install "CanoScan Toolbox Inst Carbon E" Vise "Error creating file L5, Access denied error" another dialog box clip showed "! You do not have enough access priviliges for this installation" I've tried everything suggested from checking priviledges to erasing hard drive and re installing.

Still get the message above. Maybe what you say is the problem, software compatibility issue. Thinking about buying that virtualization software and installing XP on my Mac and there I can install the scanner software. And in the bargain get a better scanner usually. But have you tried VueScan? The VueScan software did the trick! My scanner is fully functional. Really appreciate your help Mike. Take care! Jose L. MacBook Pro 2. I have the epson perfection scanner and the scanner does not show up in Photoshop CS3 or GraphicConverter 6. However the application Epson Scan 2. It just does not show up under import in Photopshop CS3 unless you select "open using Rosetta " under get info.

Then it does shows up under import in photoshop. The Epson drivers have not been updated epson site still only shows Epson Scan 2. I just bought the Epson V Photo scanner and downloaded the new Epson scanner installer 3. Both Photoshop CS3 and Readiris Pro see the scanner and work perfectly with it not needing to open with rosetta.

I asked if he could send the update download page link You can get it by going to epson. V driver download page. I leave the scanner off until needed. Basically, the Canon software was refusing to recognize the driver until I installed them in the proper order. The fix was to: Delete Canon scanner related software from Applications. Empty the Trash. Download the new Driver and Toolbox software from the Canon website. The driver is F Scanner Driver Ver.

Open the Toolbox, click the "Save" icon. Hope this helps some frustrated souls out there. I'm now using Epson Scan Utility v3. It's powered on all the time and connected via a powered 4-port USB 2. It's produced some nice results; the color restoration feature works way better than I thought possible. My only two gripes are: 1 that the software can't tell where one photo ends and the next begins on my negatives from the 's 2 the slide attachment doesn't support APS Advantix negatives.

I have about 25 rolls of this type of film and would really prefer to scan the negatives instead of the prints. I'm wondering if I can make some sort of cardboard holder that will do the trick. There are later updates available that also work. Copy utility that comes with the scanner works. Does not bring the printer settings, so it is rudimentary.

Scanners with OS X - Feedback, Tips/Tricks and Alternative Drivers

I was unable to find an update for it. All three scanners work with The also works with the Epson driver v2. The is years old but I have never had a problem using it with any version of OS X with Vuescan. The last driver that Epson put out for the was for OS8! I don't care for Nikon software so I have no idea if it works with Scanning software designed for To bad they stopped making scanners in I'm very happy about that. Nothing running in the background sucking CPU cycles. I have Photoshop CS3 but I don't use it for scanning. I always scan and open the files later.

After a while it just disappears … I have just updated to Mac OS X The information you have given here kinda suggests otherwise though. I might be able to check this out in the future. I got this impression based on something I read in a forum somewhere, so this might not be totally accurate.

Thanks Heaps! After trawling the net for ages for an answer, I finally found your solution, I can now print with my Canon Pixma MP…. Many, many sincere thanks. Your script worked first time with no problems whatsoever. You have saved me, and countless others, much time and effort, and money, too. You have also prevented untold numbers of good scanners going to landfill to pollute the Earth.

Apple Footer

Well done! Would anyone know where I can find a copy of the file, or would anyone be so kind as to send it directly my way? It would be much appreciated! Dude, you made my day! I was looking for a solution for quite some time! Thank you Jan! The solution is simple enough; replace the broken part with […]. De oplossing is eigenlijk […]. Thank YOU! Love a brilliant solution like this. I used Graphic Converter in 32 bit, and thanks to Thorsten Lemke the developer for helping me work that out he rocks.

So wonderful. And I tried it out with the Yosemite public beta. Twainbridge installs, and I could scan with my P! Does this basically use a twainbridge. You Sir, are a a true gentleman — worked first time with no problems. Anyway, thanks a lot! Fabrice from France. Thanks a lot, this is very helpful. I am using Canoscan Lide 35 and now it works fine.

Thanks a lot! Konica-Minolta bizhub C25 on Maverick I have the TwainBridge active and installed v1. Is it possible that this workaround does not work for Did you install the package for I am not sure if the Rob that also commented actually says that the PM worked both on I am using it on I think the P and PM are essentially the same machine. So it should work. But you still need the scanner drivers.

The Canon software itself might be the problem. Many thanks!! Your app worked in conjunction with doing a right-click reinstall of the Canon MP driver—all while ImageCapture is closed. I was about to ditch my Canon F. You brought it back from the dead! Thank you for working out this fix and then making it available to the rest of us. Thank you so much…have been tearing my hair out trying to get my MP working. This seems to have fixed the problem. Any other action required? Which canon driver did you use? Thanks a lot. I used the one for Thanks so much. Now I can use both.

You rock! Just got off the phone with Canon, they were no help. Now with your fix I can scan direct from Photoshop just like before. Many Thanks. Works well, but only in text not in color. The method described in this post requires the scanner drivers to already be installed. How exactly did the driver installation fail? Thank you! Like Fabrice, my MP Navigator still opens then quits after 10 seconds. But at least Image Capture works! There were no installation or operational problems at all and the scans are high quality. I have not heard a single word of someone not getting this to work on Yosemite, so it should probably work.

Are you having problems? No luck. Good news! Canon updated its driver for Yosemite. Works great! Thats good to see. I think they only do this for the more recent scanners. Which scanner are you using? This is great, Jam, thanks so much for finding the fix. Awesome work! Several people in the comments have reported that this fix also works in the Yosemite beta, so for now all seems good :.

It is possible that twainbridge might be deleted in the update, so a reinstallation should be attempted if it stops working. Do you know of a work around for this, or maybe I need something else that you know of other than the Canon driver. Do you know where all of those folders should live?

Are they just loose in the Library directory, or inside something else? You could also try the VueScan, I think it is easier to accomplish, as it is only the application. You will however have to use the application for scanning, and it is not freeware, still worth a try though. I wish you the best of luck. Uncompatible drivers and old devices quickly becomes a PITA. I was hoping that the SANE pieces would be a workaround, but evidently not.

Oh well. I recently got a LiDe 80 working with Mavericks using Sane. It also works with Vuescan now with the Sane backend and the twainbridge and twain-sane plugins. In order for this to work I had to compile the latest sources from their git repo. LiDe 80 support was added into Sane relatively recently. I can scan now using the command line or image capture, etc. Image capture scans come out distorted, though. Did you try ExactScan? Was this meant for me or in response to someone elses comment? It is also pretty native. Thank you so much. You made my day. Many thanks for making this installer package available.

After 6 hours of searching the net and trying out insane things well above my abilities this has finally done it. I appreciate you taking the time to figure this out for the rest of us. Thank you so much for this — I do now have to go a different route to get my scanner to work but it does finally seem to be operational again a Canon MP — ok not exactly up to the minute but it does what I need and I would be annoyed to have to buy a new one unnecessarily just because of the software upgrade. This brand new all in one should just work out of the box as it is supposed to be Mavericks compliant but no dice.

I had a similar problem with a very Old Epson scanner where it scanned blurry with apple drivers and ok via VueScan. Either Apple needs to make better drivers of the OEM scanner makers need to provide them…this is not acceptable. Any suggestions or workarounds would be appreciated!!! Yeah this is stupid. But new devices where compatibility is claimed should be supported.


  1. How to fix Cannot communicate with scanner message on Cannon devices??
  2. Scanners with OS X - Feedback, Tips/Tricks and Alternative Drivers.
  3. Canon CanoScan 4400F.
  4. MacInTouch Reader Reports;
  5. Scanners: Canon.

I see they have an ICA-driver on their website listed for Mavericks and Yosemite, did you try installing this one? Working perfectly using Image Capture. Suddenly, the beast came to life just minutes before a no net swish into the trash can. Nevertheless, thak you for your work! Yeh, it seems the the drivers for the canoscan f are very old. Did you try other solutions such as VueScan or Twain Sane?

Thanks for this solution. What did work was Adobe Acrobat Pro. After figuring out how to specify the geometry for cropping , it produced very nice scans. Acrobat Pro is not free, but if you have it, it removes the need for installing any fix. Thanks for the tip! Hope it helps someone else! Dear Br, it looks like you have exactly the same laptop and printer as I do, which gives me hope.

Where have you found the drivers for CanoScan NU? Or, which model drivers are you using? I will post a link from my blog. Thank you for the fix! I think some scanner turns up as available if you run Photoshop in bit mode. I guess this would pose some more memory limitations ie, like maximum 4gb for Photoshop. Theres a note note 8 on how to this here. The native Brother application does work. I was thrilled to see this discussion since I have a Canon P scanner that I could no longer use due to switching from a PC to an iMac.

Confirm whether it was installed properly. Any suggestions would be great appreciated. I tried the suggestions in the link provided but nothing. I mean what application you are trying to do the scan from? It sounds like you might be using a Canon application for scanning, you should give Image Capture a try. There have been several people reporting success with the P, so it should be possible to achieve this. Amazingly simple fix. Thank you for clarifying and saving me a few hundred dollars. I liked the P scanner so much but had given up hope until I stumbled across your discussion.

Thank you for your patience and going another round with me to finally resolve this. How pleased I am! A quick google search lead me to this: link. The scanner has been working with my PC, but not with Mac. Let me know if if works for you. Thank you for the response. Sorry for the delay. I will update in a bit.

But thank you for the suggestion. Surely there is a fix. Others seem to be having success with running the P on their iMac. Na tym blogu jest tylko jeden wpis. Some users have reported success with the F, so it should be possible to get working. Do you only get a solid color when doing preview scans also? I have read some people have problems with certain file-formats. Did you try your scanner on another computer making sure it is not a hardware problem?

Could the lamp or something be failing? For another user reinstalling the scanner driver from the cannon website helped sort his issues with garbled scanning. Thank you, will give that a go…. Hi, many thanks for your help. I was so annoyed when I discovered that my PM is not opertional under Yosemite, but with your solution it works. Really cool And altough the drivers from Canon were only listed up to Mavericks, it works for me on my iMac with Yosemite installed from last week.

I see that the drivers are now also listed up to Yosemite, the Probably not too many changes to this in Yosemite. I see they also have an ICA driver ver 3. Also out of curiosity, did you have both the twain driver, Thank you so much Janegil. It was looking bleak for my old Pixima MP with no drivers available on the Canon website after the Yosemite upgrade to my iMac.

Scanning has now resumed as normal thanks to your efforts and that natty little Bridge for a Thing Without An Interesting Name. I hate discarding a working tool before its time. I managed to get my new MacBook Air I really appreciate it. It took me all day, but I finally found your page. Thanks a lot!!!!! Any ideas? One user has reported here that a scan produced only one solid color after upgrading to yosemite. Can I ask if you upgraded or performed a clean install of Yosemite.

If not, did you use the package from my site in Mavericks as well? Or in case do it manually. Sadly I only discovered it this morning.

fixed : use unsupported scanner in OSX 10.11 El_Capitan

But I tried it in an old Mac still running Mavericks. Could change it, if I had different ones. Although I did not know how to uninstall the existing drivers, I followed on your tip that it might be caused by the drivers, so I installed new ones on top. The driver on Canons webpages are not made to work on intel processors.

The printer also does not seem to be compatible with VueScan or TwainSane. A workaround could be to figure out which OS this scanner could be used with, and install a virtual machine to scan through. Not the most user-friendly, but it would probably work. I think only bit windows versions are supported. Thanks a lot, it works great for my Canon MP on Yosemite.

I downloaded the olds drivers for Lion on Canon website. My multifonction printer is fully fonctionnal. Mon imprimante multifonction est maintenant parfaitement reconnue. I am having a similar problem with my Microtek scanner. Microtek says they no longer support my scanner after Snow Leopard. I have been tearing my hair out for the last week trying to get the scanner to work.

Do you think this fix would work for me? Would be great if you drop an update if you try it out :. Lack of customer support here. Theres also a SANE solution you can try. Check out this post by macmanus. Thanks janegil. I tried the Mavericks one but it said it was not compatible with Yosemite. Still trying! Thank you very much, Jan! Using this I was finally! You just save me a couple of hundred! My Canon Imageformula P now works under Yosemite.

It had previously worked under Mavericks but the Yosemite upgrade rendered my scanner inoperable until I read about your fix. I had previously spoken to the Canon support help-line but they were completely useless. It makes you wonder just what is happening within that organisation…. You should put your ass on that scanner to show them what you think ….

Folks will get wise to such behaviour whether it be a sales ploy or just incompetence. It can now be seen by imagecapture.

Support Tool Contact

Many thanks. I was only able to scan from within Adobe Acrobat Pro. That worked, but was inconvenient and limited my options. When I recently installed Yosemite, I lost even that capability. Thanks again! A big thank you for supplying this information. This solution has worked beautifully. And so simple! My Canoscan Lide 20 is still not recognised by Image capture.

Canon 4400f Драйвер Windows 10

Can anyone please tell me what to do? You need a driver in addition to this package. It seems Canons drivers are too old for this scanner to be used with Yosemite, some other people commenting here has had success using it with the SANE drivers, and this package. It works independently and through Photoshop. Many thanks, it works very well with my Samsung SCX My husband and I have been working on this since upgrading to Yosemite last week.

I have been practically tearing my hair out with frustration! This upgrade to Yosemite has been extremely painful, but thanks to you I have a working scanner again! I upgraded from Mavericks and I think the transition to Yosemite has been one of the most painfree updates I have done with OS X this far. I skipped Mavericks and have been having the worst time. We are now telling clients to go to Mavericks and then Yosemite. Always better to do a small upgrade! You have no idea how much your sharing the fruits of your hard work has meant to me. I have and old Notebook laptop with Windows and have to use that if I want to scan and print…sigh!!

Then I came upon this thread. Perhaps you could help me by describing how you got yours working OK. Regards Derek A. You need to use the installer from this page together with the old Canon driver. Another satisfied customer! My ancient LIDE35 which I love for both the image fidelity and the extremely low profile seems to once again be in the land of the living. This works perfectly with my Canon P Thank you thank you! Would someone help me finding the driver. It seems the comment earlier refers to SANE, which is another package like thing of drivers.

It can be found here. I dont think it supports Yosemite yet though, hopefully this will happen soon. If you are not running Yosemite, a post by MacManus has a short howto , and I think will also be updated once Yosemite is released. Thanks so much for all your dedication. All I got was gray when scanning on my trusty Canon Lide F. Canon does not provide a driver for Thanks very much.

I also have a Canon Lide F and has a new Mac desktop. This fix worked for me, using the driver on the Canon website made for the Thank you for doing this work. Take care. I tried the driver for Then found this site from a Google search. Works like a charm! You still need the Get the TWAIn bridge app. Install all 3. Open toolbox and scan something. In any event, how do you implement your Fix once it has been downloaded and installed?

I have not tried my solution with any of the applications provided by Canon. This worked perfectly for my Brother DSmobile Thanks so much for your help! Works great with Yosemite, Canoscan F. Finally ditched the crappy Canon scanning software! Thanks for clear headed thinking, simple solution. I was amazed at the threads and misinformation around this topic. The solution reinstalling older Apple executable while using most current scan driver is really a safe way to go.

It works for my Canoscan F with Yosemite I can use the scanner buttons again! My open questions are now: Why Apple deny the access to the scanner? Are the buttons of this scanner working with Yosemite without the usage of the old TwainBridge App? And if so, why? What is the Yosemite way for writing scanner drivers which are listend into digital image app? Not getting many hits googling for that though. I use mostly the buttons when i work with the scanner. If so, then the root cause is at the side of Canon.

My CanoScan Lide 90 is back up and running. My CanoScan F works again! Thank you so much for saving me the cost of replacing a perfectly good and expensive scanner. It works great now!! Thank you, Jan Egil, so very much! I spent several hours and tried all sorts of advice from the Xerox forums and elsewhere with no success. This, however, was easy peezy! Again, many, many thanks.

Hi Janegil, You are a star, thank you very much for providing this installer package and link to the drivers. When I recently upgraded to Yosemite I have just installed the last available driver fosxen for this scanner from Canon for Lion? I have scanned some photographs and all the previous functionaliy seems to be there. That is a minor inconvenience though, most importantly I have my scanner with slide scanning capbi;ity back.

Again, thank you very much. Fixing these kinds of problems are way beyond my capabilities and having people like you doing it is wonderful. Unbelievable that a simple piece of kit like a flatbed scanner can get shot down so easily. It seems the drivers for the Lide are pretty up to date from their date on Canons website.

Try reinstalling their drivers. I would possibly try the ICA driver listed there first. Yeah it seems like the drivers for this scanner is pretty old. Thanks so much! My CanoScan F works now with mac I am happy now, that I can use my well working scanner. Hate to throw away things which are still good! You did a great job for sustainability! I feel the same as everyone else, why for the sake of a bit of software writing, are we expected to throw out working equipment. You also have to download a twain driver for one of the older OS X versions. Not sure if the scanner appears in system preferences.

I have mostly only tried with Image Capture. I just moved to Yosemite, and your patch was a real lifesaver. Worked like a charm for my Canon Lide I just reactivated a Canoscan F under Thank you soooooo much! I can communicate with my Canoscan F after the fix thanks a stack! Any suggestions will be most welcome. Try note 7 here. My iMac can now see the scanner as a device in applications, I can use the buttons — as well as assigning different functions to those buttons.

It no longer does so. Is there some way to set scanner preferences? According to this source: […]. My scanner then showed up in my available devices in Photoshop. Thanks a bunch!